Comment faire une somme avec des conditions sur Excel: les fonctions SOMME.SI et SOMME.SI.ENS

Bloqué sur Excel?
Obtenez rapidement une réponse personnalisée en posant votre problème sur le forum: forum.formuleexcel.com
C'est gratuit!

Calcul complexe avec des conitions

Dans un article précédent je vous avais expliqué comment faire des sommes sur Excel. Nous allons aller plus loin et voir comment sommer seulement certaines cellules en appliquant des conditions.

Prenons l’exemple d’un marchand de meubles qui souhaite calculer 2 chiffres d’affaires: le CA effectué en vendant des chaises et le CA effectué en vendant des tables aux particuliers. Comment les calculer automatiquement?

Tableau de données pour sommes conditionnelles
Tableau de ventes

Faire une somme avec une seule condition avec la fonction SOMME.SI

Utilisation de SOMME.SI pour faire une somme conditionnelle sur Excel
Utilisation de SOMME.SI

Dans le premier cas nous allons utiliser la formule SOMME.SI . Cette fonction permet de sommer les cellules dans une colonne, uniquement si la cellule dans une colonne parallèle vérifie une certaine condition. Dans notre cas, on sommera les chiffres d’affaires de la colonne E uniquement si la cellule sur la même ligne dans la colonne B est égale à « Chaises »

La syntaxe de cette fonction est la suivante:

=SOMME.SI( Plage de cellules devant respecter la condition ; Valeur à respecter ; Plage de cellules à sommer)

Dans notre cas, elle devient =SOMME.SI(B2:B13; »Chaises »;E2:E13)

Faire une somme avec plusieurs conditions avec la formule SOMME.SI.ENS

Faire une somme avec plusieurs conditions sur Excel avec SOMME.SI.ENS
Utilisation de SOMME.SI.ENS

Dans le second cas, nous avons besoin de faire une somme avec plusieurs conditions. Ce n’est pas possible avec SOMME.SI mais c’est possible avec la formule SOMME.SI.ENS

Le fonctionnement de cette fonction est similaire à SOMME.SI mais elle permet de spécifier plusieurs plages de données devant chacune respecter un critère. La syntaxe de cette formule est:

=SOMME.SI.ENS( Plage de cellules à sommer; Plage devant vérifier le critère n°1 ; Valeur à respecter n°1;  Plage devant vérifier le critère n°2 ; Valeur à respecter n°2;…etc)

Vous pouvez mettre autant de critères que vous le souhaitez. Dans notre exemple on va sommer la colonne E si on trouve « Tables » dans la colonne B et « Particulier » dans la colonne C, la formule devient donc:

=SOMME.SI.ENS(E2:E13;B2:B13; »Tables »;C2:C13; »Particulier »)

Répondez à ce sujet sur le Forum Formule Excel

Anciens commentaires

Comments are closed.